Issues accessing Westpac Invoice Finance
Incident Report for Qvalent
Resolved
This incident has been resolved.
Posted Feb 04, 2020 - 10:37 AEDT
Investigating
Please be advised that we are currently aware of issues accessing Westpac Invoice Finance. The team are currently investigating the cause of the issue. We expect the service to be available at 11:30am . We apologise for the inconvenience.
Posted Feb 04, 2020 - 09:38 AEDT
This incident affected: Invoice Finance.